Issue with Pulse audio upgrade/install on Ubuntu / Elementary OS

Unable to upgrade pulseaudio on Ubuntu 16.04

 · 1 min read


The following packages will be upgraded:
pulseaudio
1 upgraded, 0 newly installed, 0 to remove and 37 not upgraded.
2 not fully installed or removed.
Need to get 0 B/766 kB of archives.
After this operation, 4,096 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
(Reading database ... 341675 files and directories currently installed.)
Preparing to unpack .../pulseaudio_1%3a8.0-0ubuntu3.8_amd64.deb ...
Unpacking pulseaudio (1:8.0-0ubuntu3.8) over (1:8.0-0ubuntu3.7)...
dpkg: error processing archive /var/cache/apt/archives/pulseaudio_1%3a8.0-0ubuntu3.8_amd64.deb (unpack):
unable to create '/usr/share/pulseaudio/alsa-mixer/paths/hdmi-output-1.conf.dpkg-new'
(while processing '/usr/share/pulseaudio/alsa-mixer/paths/hdmi-output-1.conf'):
Permission denied
Processing triggers for dbus (1.10.6-1ubuntu3.3) ...
Errors were encountered while processing:
/var/cache/apt/archives/pulseaudio_1%3a8.0-0ubuntu3.8_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)



Solution:
The directory /usr/share/pulseaudio/alsa-mixer/paths was set as immutable. I changed it by running sudo chattr -Ri /usr/share/pulseaudio/alsa-mixer/paths. And Everything was fixed.

1 comment
Apoorv Soral May 17, 2020

The directory /usr/share/pulseaudio/alsa-mixer/paths was set as immutable. I changed it by running sudo chattr -Ri /usr/share/pulseaudio/alsa-mixer/paths. And Everything was fixed.

Add Comment